Discuss, share information, ask questions, and show off your expertise on Yoder ACS Pellet Cookers.

Click the links below to go directly to available resources:
**Pellet cookers** - YS480, YS640
**Competition Pellet cookers** - YS480 Comp, YS640 Comp, YS1500 Comp, Cimarron Comp
**Pellet Cooker Warranty**
June 8th, 2020, 10:00 am
* Abilene ** Abilene *
  • Joined: May 8th, 2020, 7:41 am
  • Posts: 2

Ok so I was smoking some chicken breasts this past weekend, and noticed something early on in the cook. One of the probes stopped working. Now the cooker/probes are only a month old so I didn't think the probe was bad. As soon as I pulled the probe from the meat it started sending temp info again. When I put it back in the meat you could see the temp go down to about 34 degrees and then go blank.

Once I got the probe in a different place in the meat where the temperature didn't go below freezing it worked just fine until the end of the cook.

So is there a lower limit on these temp probes before they just stop?

June 25th, 2020, 1:20 am
* Abilene ** Abilene *
  • Joined: January 1st, 2020, 2:07 pm
  • Posts: 1

I just put on 2 pork shoulders (boneless apparently, new for me). When I opened the package to season them a few hours, the center of the package where the two butts met was frozen. Well, fast forward 6 hours, and I'm putting them on my 640. Got them on the rack, inserted the probes, spritzed, then went in to wash. Checked my app, and I had zero readings from the probes anymore. 1.5-2 hours later, they started to register again. Booth are reading a minimum of 31.5F. I thought for sure I had fried them with the spritz, but thankfully it just looks like a low-range limit.

June 28th, 2020, 6:49 pm
* Abilene ** Abilene *
  • Joined: June 15th, 2020, 9:51 pm
  • Posts: 4

I also noticed this same thing.
I did a 5lb boneless leg of lamb on Father’s Day. Mine would not read below 34, but once it hit 34, the probe worked as expected.

Return to ACS Pellet