Click the links below to go directly to available resources:
**Frequently Asked Questions**
**Register Your Yoder Cooker**
**Find a Dealer**
**The Yoder Smokers Blog**
May 8th, 2020, 2:48 pm
* Abilene ** Abilene *
  • Joined: July 11th, 2019, 3:46 pm
  • Posts: 2

I have a YS640 pellet smoker. Build date 8-22-2017 and I bought it end of Oct 2017. FW U29

This past Sunday I fired it up to do some cooking. It showed the firmware# on the display and then showed the default temp of 350. Next came downward dashes.

The downward dashes is something that has never happened before. It never came up to temp nor did it ever show what the true temp was. No matter where I set the temp, it always showed downward dashed.

I shut the unit down and tried a restart, same thing.

Shut down again. Unplugged unit and waited a bit. Plugged back in and restarted. Same result.

Ive emailed just service with no answer. Also tried calling on the phone. Call doesnt go through. I also dropped a line to All Things Barbecue to see if they had any ideas. And so far, no answer from them either

I realize that maybe these places are not open due to Covid-19. Which is why im reaching out here on this forum

Any ideas or advice? I wonder if its a bad thermocouple? Should be under warranty?

Thanks in advance

May 12th, 2020, 11:50 am
* Abilene ** Abilene *
  • Joined: July 11th, 2019, 3:46 pm
  • Posts: 2

I did hear back from Yoder. They agreed that it was a bad thermocouple and are sending me a new one under warranty

Return to Manuals, Troubleshooting, Best Practices, FAQs, Cooker Registration